Questões de Informática Básica / Microinformática da CESGRANRIO

Na implementação da memória virtual em sistemas operacionais, é necessário definir, dentre outros elementos, a política de substituição de páginas. Esses algoritmos escolhem qual página deverá deixar a memória real (chamada página vítima) e voltar ao meio secundário de armazenamento, a fim de ceder espaço à outra página requisitada pelo processador e atender à requisição de falha de página. Uma das formas de implementação desses mecanismos de substituição de páginas prevê a utilização de bits auxiliares associados às páginas.

Nesse contexto, qual a função do bit de sujeira (dirty bit)?

  • A. Evitar a utilização de um algoritmo de substituição de páginas da classe local.
  • B. Evitar que uma página seja eleita como “vítima”, ou seja, tenha de deixar a memória.
  • C. Indicar quando uma página foi alterada durante a execução de um processo.
  • D. Indicar se a página é candidata à ocorrência de trashing.
  • E. Indicar se a página foi referenciada dentro de um intervalo de tempo.
Clique em uma opção abaixo para responder a questão:

O termo Big Data é bastante conhecido pelos profissionais de tecnologia da informação, especialmente aqueles envolvidos com bancos de dados, inteligência de negócios, sistemas de informações e sistemas de apoio à decisão.

Uma característica inerente a esse conceito é a da

  • A. complexidade das suas fontes de informação, o que demanda a necessidade de sua prévia limpeza, integração e transformação.
  • B. estabilidade da taxa de geração desses dados, o que garante sua utilização confiável na geração analítica de informação com independência temporal.
  • C. heterogeneidade do conjunto de dados, empregada em dados originalmente estruturados ou semiestruturados.
  • D. qualidade das fontes de dados, por conta dos padrões de expansão e de retenção reveladores da ordem existente nos dados.
  • E. escalabilidade, que, na sua forma original, possui alto valor granular quando comparado ao de seu volume.
Clique em uma opção abaixo para responder a questão:

A célula D1 do trecho de planilha Excel (versão 2016, em português) a seguir foi preenchida com a fórmula =SE(SOMA(A1:$C$1)>=SOMA($A$1:C2);MÁXIMO(A1:$C$4);SOMA(A1:C1))

Qual é o valor da célula D4 após ser copiado o conteúdo da célula D1?

  • A. 7
  • B. 12
  • C. 15
  • D. 17
  • E. 33
Clique em uma opção abaixo para responder a questão:

A sentença correta para realizar esse procedimento é:

  • A. =SE(D2>C2;SE(B2<=1600;"cobrar juros";"pendente");"ok")
  • B. =SE(E(D2>C2;B2>1600);"cobrar juros";SE(B2>1500;"pendente";"ok"))
  • C. =SE(D2>C2;SE(B2>1600;"cobrar juros";"pendente");"ok")
  • D. =SE(E(D2>C2;B2>1500);"cobrar juros";SE(B2>1600;"pendente";"ok"))
  • E. =SE(E(D2>C2;B2>1500);SE(B2>1600;"cobrar juros";"ok");"pendente")
Clique em uma opção abaixo para responder a questão:

No Brasil, os números telefônicos têm dois números que indicam o código de área e oito ou nove números que indicam o número do assinante. Desenvolvendo uma aplicação na área de trabalho do Microsoft Access, um programador desejava uma máscara de entrada para usar em um campo com o tipo de dado Texto Curto, com as seguintes propriedades:

Qual a máscara de entrada mais adequada para atender ao desejo do programador?

  • A. !(00)09999-9999;1
  • B. !(99)90000-0000;0
  • C. !(99)90000-0000;1
  • D. (00)09999-9999;0
  • E. (99)90000-0000;1
Clique em uma opção abaixo para responder a questão:
Um arquivo docx, criado com o MS Word 2010, foi aberto com sucesso mediante digitação da senha de abertura correta e da senha de gravação correta. Em seguida, esse arquivo foi salvo no formato Rich Text (.rtf). Nessas condições, o novo arquivo (.rtf)
  • A. será protegido, tanto para abertura como para gravação, por uma senha padrão, correspondente ao nome do usuário do MS Word usado para criar o arquivo original.
  • B. será protegido, tanto para abertura como para gravação, pelas mesmas senhas de abertura e de gravação do arquivo original.
  • C. não será protegido por senha de abertura nem de gravação.
  • D. será protegido de abertura pela mesma senha de abertura do arquivo original, mas não será protegido por senha de gravação.
  • E. será protegido de gravação pela mesma senha de gravação do arquivo original, mas não será protegido por senha de abertura.
Clique em uma opção abaixo para responder a questão:

Na empresa onde um indivíduo trabalha, vários funcionários compartilham o mesmo computador rodando o Windows 10 em português. Um desses funcionários precisa usar o computador desse indivíduo, mas este não quer fechar os programas e arquivos com os quais está trabalhando no momento.

Que opção esse indivíduo deve escolher para resolver essa situação?

  • A. Trocar usuário
  • B. Bloquear
  • C. Suspender
  • D. Desligar
  • E. Hibernar
Clique em uma opção abaixo para responder a questão:

A Figura abaixo reproduz, de forma ampliada, um botão representativo de um recurso do Excel 2016.

Qual é o recurso representado?

  • A. Aumentar espaçamento entre linhas
  • B. Alinhar parágrafo pela margem inferior
  • C. Ajustar texto pela margem superior
  • D. Mesclar e centralizar
  • E. Quebrar texto automaticamente
Clique em uma opção abaixo para responder a questão:
Considerando a Figura 1, que fórmula pode ser utilizada para determinar, na célula K17, dentre os estados da região norte, o valor de maior incidência dentre aqueles com ocorrência de mais de 5.000 casos em 2016 ?
  • A. =MÁXIMOSES($K$3:$K$16;$F$3:$F$16;"norte";$I$3:$I$16;">5000")
  • B. =MÁXIMO($K$3:$K$7;$F$3:$F$7;"norte";$I$3:$I$7;">5000")
  • C. =E($K$3:$K$16;$F$3:$F$16;"norte";$I$3:$I$16;">5000")
  • D. =PROCV($K$3;$F$3:$K$16;"norte";$I$3:$I$16)
  • E. =SE($K$3:$K$16>5000;"norte";$I$4:$I$16)
Clique em uma opção abaixo para responder a questão:
Considerando a Figura 1, que fórmula pode ser inserida na célula K17 para determinar o número total de casos ocorridos nos estados da região nordeste em 2015?
  • A. =SOMA ("nordeste"; F8:F11;H8:H11)
  • B. =SOMASE("nordeste"; F8:F11;H8:H11)
  • C. =SOMASE(F8:F11;"nordeste";H8:H11)
  • D. =SOMASES("nordeste";F8:F11;H8:H11)
  • E. =PROCV(F8:H11;"nordeste";H8:H11)
Clique em uma opção abaixo para responder a questão: